Jump to content

Recommended Posts

This is probably the wrong place to post this, but I didn't see anywhere for general issues/questions.

 

I just imported the UMA Hair pack and ran the Hairstyles Scene that comes with it. All of the hairstyles are blocky black and white and won't color.

Any faces with beards are getting really bad artifacts. They turn black in any kind of shadow.

Any idea what I might be missing?

Screenshot 2019-04-09 17.18.43.png

Share this post


Link to post
Share on other sites

I figured out some of the issues.

Several of the male face Normal textures import as generic textures. Once I changed them to Normal textures, nearly all of the issues vanished.

My remaining issue may be the result of my severe lack of experience with UMA, or it might be a bug that crept in after an UMA update... I'm unsure.

This is all done in the HairStyles demo scene.

The issue is that the hair remains white when I set the color inside of the Dynamic Character Avatar script.

If I play the demo scene, open the UMARenderer, and change the Diffuse Color in the UM_HairPack_Mastermaterial, then the hair tints correctly.

Because it's not accepting the Dynamic Character Avatar tint, I'm unable to choose a color prior to spawning the UMA.

 

Any idea how to fix that?

I'm very new to UMA, so I don't know how all of the different scripts interrelate yet.

 

 

Share this post


Link to post
Share on other sites

You first need to go to the Hair Recipes

For Example

Highlight  UM_HairStyle_E_Recipe (ie show the inspector)

Goto the Shared Colors section and Add Shared Color

Name It Hair (You will need to expand the section to name it)

Scroll down to the Overlay for the Hair Style and select the Use Shared Color.  Select Hair from the dropdown list if not already selected)

 

Run scene and highlight Female (4)  (Hope we have the same scene...lol)

You should now be able to play with the hair color slider and see the hair change.

 

Hope this helps

 

uma_color.png

  • Like 1

Share this post


Link to post
Share on other sites

Hello, all. I'm having a similar problem. Most hairstyles work fine, but there are a few that show up weird. I've done all of the above (shared color, changing normal map, etc.) but nothing seems to work. If I fool around with all of the colors, I can get some of the colors to change (see pic 2), but the silver part remains. It feels like I need to somehow have multiple textures/colors, but I can't figure it out.
Thanks!

 

 

silver.PNG

hair2.PNG

Share this post


Link to post
Share on other sites

You must use the shader pack for the hairpack, apologies if this wasn't mentioned in a readme in the pack, please download and use this

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.